ITS security advisory: Update Windows systems to prevent ransomware and other attacks
Incident Report for Davidson College
Resolved
This incident has been resolved.
Posted 6 months ago. May 30, 2017 - 14:32 EDT
Monitoring
You may be aware of a “ransomware” computer attack that has made news headlines over the past 36 hours. This attack presents an ongoing threat to networks and Windows computer users around the world, including colleges like Davidson and your own personal home computers.

At this time, the College has not detected activity related to the attack, known as WannaCry, on our network. While WannaCry’s spread has been slowed, researchers are finding other versions of this attack continuing to spread. Here’s the latest we know and the best advice we have at this time:

1) Update Windows systems: ITS-managed servers, faculty/staff Windows workstations, and lab/classroom computers have been or are being patched (inoculated) against this threat. But, student computers and faculty/staff home computers may be at risk. Check your Windows computer to make sure it has the latest Microsoft updates, but especially the update for MS17-010. (More info: https://technet.microsoft.com/en-us/library/security/ms17-010.aspx)

2) Special attention for Windows XP, 8, and Server 2003: If you’re running an old/end-of-life version of Windows, beware - Microsoft does not ordinarily provide security updates for these, so your system is at great risk. Due to the extraordinary nature of this risk, Microsoft has released a special patch that you must download and install. (More info: https://blogs.technet.microsoft.com/msrc/2017/05/12/customer-guidance-for-wannacrypt-attacks/)

3) Beware phishing emails: WannaCry and its successors are blocked by the “firewalls” at Davidson and most organizations. This attack is dangerous because it uses phishing emails to bypass those defenses, and once installed on a single computer, the malware combs the network to attack other computers, too. Please, be even more careful than usual of following “phishing” links or opening unexpected attachments — don’t become our campus “patient zero!”

4) Stay off networks until patched: Because this attack spreads over networks as well as email, unpatched computers are at risk whenever and wherever they are on the Internet. Until you’ve run Windows updates (or manually patched an unsupported OS), we recommend keeping at-risk computers off all wi-fi and wired networks.

We know these security threats continue to grow more frequent and we share your frustration at the time and effort they require! At ITS, we continue to take steps to improve campus cybersecurity. Thank you for your help in keeping Davidson computers and data safe.

Kevin Davis

Deputy CIO
Davidson College ITS
Posted 6 months ago. May 13, 2017 - 14:16 EDT