Voicemail access problems
Incident Report for Davidson College
Resolved
This incident has been resolved.
Posted 2 months ago. Sep 14, 2017 - 16:56 EDT
Identified
Some Davidson staff members cannot log into their personal voicemail boxes by phone. Voicemail delivery by email is still accessible for all users. We are working with our vendor, Cisco, to resolve this problem and will provide a further update as soon as we can.
Posted 2 months ago. Sep 12, 2017 - 14:08 EDT