Alumni email, PowerBI access problems
Incident Report for Davidson College
Resolved
Alumni email account license access was fully restored on Friday, September 29. We apologize for any inconvenience.
Posted about 2 months ago. Oct 02, 2017 - 13:19 EDT
Investigating
Some alumni cannot access their email accounts, and some faculty/staff users of PowerBI licenses are finding them inaccessible at this time. We are working with our vendor, Microsoft, to resolve a problem with our Office 365 service. We apologize for any inconvenience.
Posted 2 months ago. Sep 14, 2017 - 11:33 EDT