Mac/Windows computer login, password change problems
Incident Report for Davidson College
Resolved
The problem of logging into Windows and Mac lab and classroom podium computers has been resolved as has the problem with resetting Davidson passwords.
Posted 26 days ago. Aug 30, 2017 - 15:32 EDT
Monitoring
At this point we believe we have resolved the issue. Several other campuses across the country have reported similar issues, and we have worked with them to troubleshoot. Successful tests have occurred on a variety of systems in different scenarios. However, it is still possible users could experience problems logging into college computers and resetting Davidson passwords.

We will continue to monitor the situation, but if you cannot log into college computers or have any other issues, contact the service desk at its@davidson.edu or 704-894-2900. If you have trouble logging into a classroom podium computer, you can also press the "Help" button.
Posted 26 days ago. Aug 30, 2017 - 12:19 EDT
Identified
ITS is still working to identify and solve the problem affecting Windows and Macintosh computer logins (including workstations, lab systems, and classroom podium computers.) We will post further updates as we have them.
Posted 26 days ago. Aug 30, 2017 - 10:11 EDT
Investigating
ITS has received reports of some problems accessing Windows resources. This may include problems logging on to Windows computers, as well as errors when trying to change a Davidson password on Windows systems and to join a system to the Davidson domain. ITS is investigating and we will provide more information as we have it.
Posted 26 days ago. Aug 30, 2017 - 08:59 EDT