Davidson Domains outage
Incident Report for Davidson College
Resolved
Our service provider confirms that Davidson Domains is back online and operating correctly.
Posted 6 months ago. Apr 04, 2017 - 21:02 EDT
Monitoring
Davidson Domains is back online. We are waiting for our service provider to confirm that their servers have recovered.
Posted 6 months ago. Apr 04, 2017 - 20:52 EDT
Identified
Update from Davidson Domains hosting provider: "We have identified the underlying cause as a storage volume outage on Digital Ocean, one of our upstream providers, accounting for outages across multiple servers in the east coast region." A resolution is pending.
Posted 6 months ago. Apr 04, 2017 - 20:11 EDT
Investigating
The Davidson Domains hosting provider, Reclaim Hosting, is experiencing a major outage. Davidson Domains will be inaccessible to Davidson users until Reclaim identifies and addresses the cause of the outage. We'll update this incident as soon as we know more.
Posted 6 months ago. Apr 04, 2017 - 20:07 EDT