Online password reset unavailable for some users
Incident Report for Davidson College
Resolved
ITS fully restored online password reset functionality at approximately 1:50pm on Wednesday, April 5. We apologize for the interruption. All Davidson users should again be able to change their passwords using the resetpassword.davidson.edu web site.
Posted 6 months ago. Apr 05, 2017 - 13:57 EDT
Identified
ITS has learned some users cannot change their Davidson account password through our official online reset tool (resetpassword.davidson.edu). We believe we have identified the source of the problem and are working with our vendor to implement a resolution.

ITS will provide further updates on Wednesday, April 5 as to the status and estimated time to resolution.
Posted 6 months ago. Apr 04, 2017 - 21:33 EDT